Index Page and Help |
FSCK(8) OpenBSD System Manager's Manual FSCK(8)
fsck - filesystem consistency check and interactive repair
fsck [-dvpfny] [-l maxparallel] [-t fstype] [-T fstype:fsoptions] special
| node ...
The fsck command invokes filesystem-specific programs to check the spe-
cial devices listed in the fstab(5) file or on the command line for con-
sistency. The options are as follows:
-d Debugging mode. Just print the commands without executing them.
Available only if fsck is compiled to support it.
-f Force checking of filesystems, even when they are marked clean
(for filesystems that support this).
Limit the number of parallel checks to maxparallel. By default,
the limit is the number of disks, running one process per disk.
If a smaller limit is given, the disks are checked round-robin,
one filesystem at a time.
-n Cause fsck to assume ``no'' as the answer to all operator ques-
tions, except ``CONTINUE?''. This is assumed to be the default
when dealing with filesystems currently mounted writeable.
-p Enter preen mode.
Invoke fsck only in the comma separated list of filesystem types.
If the list starts with ``no'', invoke fsck only in the filesys-
tem types that are not specified in the list.
-v Print the commands before executing them.
-y Cause fsck to assume ``yes'' as the answer to all operator ques-
List of comma separated filesystem specific options for the spec-
ified filesystem type, in the same format as mount(8).
/etc/fstab filesystem table
fstab(5), fsck_ext2fs(8), fsck_ffs(8), fsck_msdos(8), fsdb(8), mount(8)
OpenBSD 3.4 September 23, 1996 1