Man Page copied from OpenBSD Manual Pages
CHOWN(8) OpenBSD System Manager's Manual CHOWN(8)
chown - change file owner and group
chown [-R [-H | -L | -P]] [-f] [-h] owner[:group] file [...]
chown [-R [-H | -L | -P]] [-f] [-h] :group file [...]
chown sets the user ID and/or the group ID of the specified files.
The options are as follows:
-H If the -R option is specified, symbolic links on the command line
are followed. (Symbolic links encountered in the tree traversal
are not followed.)
-L If the -R option is specified, all symbolic links are followed.
-P If the -R option is specified, no symbolic links are followed.
-R Change the user ID and/or the group ID for the file hierarchies
rooted in the files instead of just the files themselves.
-f Don't report any failure to change file owner or group, nor modi-
fy the exit status to reflect such failures.
-h Change the user ID and/or the group ID on symbolic links. The -R
and -h options are mutually exclusive.
The -H, -L, and -P options are ignored unless the -R option is specified.
In addition, these options override each other and the command's actions
are determined by the last one specified.
The owner and group operands are both optional; however, one must be
specified. If the group operand is specified, it must be preceded by a
colon (`:') character.
The owner may be either a numeric user ID or a user name. If a user name
is also a numeric user ID, the operand is used as a user name. The group
may be either a numeric group ID or a group name. If a group name is al-
so a numeric group ID, the operand is used as a group name.
Only the superuser is permitted to change the owner of a file.
The chown utility exits 0 on success or >0 if an error occurred.
chgrp(1), find(1), chown(2), fts(3), symlink(7)
Previous versions of the chown utility used the dot (`.') character to
distinguish the group name. This has been changed to be a colon (`:')
character so that user and group names may contain the dot character.
The chown command is expected to be IEEE Std 1003.2 (``POSIX.2'') compli-
OpenBSD 3.4 January 25, 1997 1
SEE ALSO |